Requisiti Prestashop

Requisiti Prestashop

Generalità su Prestashop

PrestaShop è la soluzione di e-commerce pronta all’uso, utilizzabile per far prendere vita alla tua attività on-line. Nasce nel 2007 e, a differenza di altri CMS come WordPress (più ad uso generico), Prestashop è pensato per lo sviluppo e la gestione di un e-commerce, sia base che avanzato. Dispone infatti di un evoluto sistema di gestione scritto in PHP, e supporta svariate lingue nativamente.

È possibile scaricare PrestaShop (versione “su misura” gratis, oppure assistita a circa 19,90 € al mese) dal sito ufficiale.

Pubblicità:

Requisiti hardware

PrestaShop per funzionare in modo corretto possiede i seguenti requisiti.

In locale (solo per sito test o in localhost):

  • sistema operativo indifferentemente Windows, Mac, Linux
  • software free come WampServer o EasyPHP per Windows, Xampp o Bitnami per Windows e Mac, MAMP per Mac, il quale fornirà a sua volta:
    • web server Apache 1.3, Apache 2.x, Nginx o Microsoft IIS
    • supporto PHP almeno 5.4
    • MySQL 5.0+ installato e un database vuoto

In remoto / su internet, invece, cioè per siti pubblici o in produzione:

  • prima di tutto serve un dominio del tipo tuoecommerce.it
  • poi devi trovare un servizio di hosting che supporti
    • uno tra Apache 1.3, Apache 2.x, Nginx, Microsoft IIS
    • PHP almeno 5.4 (consigliato 7.x)
    • MySQL 5.0+ installato e un database vuoto
    • Accesso FTP

Prestashop è scalabile con facilità su server di qualsiasi taglia, e si adatta facilmente a numerose taglie / numero di visitatori mensili.

Configurazione specifica

  • Nella configurazione PHP, impostare memory_limit su 124M e upload_max_filesize su 16M
  • Estensioni PHP: Mcrypt, OpenSSL, Zip, Curl, GD,PDO

Requisiti sistema operativo

Sono supportati tutti i principali sistemi operativi Linux (consigliato) e Windows; Prestashop è stato testato con successo su qualsiasi sistema operativo, ma Linux rimane preferibile per via della gestione del filesystem e per il fatto di avere maggiore documentazione free disponibile in rete.

Requisiti server

Vengono supportati ufficialmente

  • Apache 1.3, Apache 2.x, Nginx, Microsoft IIS

Requisiti database

È supportato il seguenti database:

  • MySQL 5.0+

Ovviamente il PHP deve disporre di un modulo di collegamento al tipo di database scelto (ad esempio mysqli).

Requisiti PHP

Ci vuole PHP versione 5.4 minimo, ma è suggerito l’uso di PHP 7 sulle versioni più recenti. Sono anche richiesti i seguenti moduli PHP obbligatoriamente perchè Moodle possa funzionare in ogni sua parte: Mcrypt, OpenSSL, Zip, Curl, GD,PDO.

Pubblicità:

Certificato SSL: meglio utilizzarlo

È fortemente consigliata l’installazione di un certificato SSL: Let’s Encrypt per tutte le pagine web, eventualmente un certificato a pagamento per poter implementare in modo sicuro un sistema di pagamento (gateway) diverso da PayPal.

(fonte)


Informazioni sull'autore

Salvatore Capolupo

Ingegnere informatico, consulente SEO, copywriter ed ideatore di trovalost.it. Di solito, passo inosservato: e non ne approfitto neanche un po'.
Ti piace questo articolo?

0 voti

Su Trovalost.it puntiamo sulla qualità dei contenuti da quando siamo nati: la tua sincera valutazione può aiutarci a migliorare ogni giorno.