Funzioni in Excel: cosa sono e come si usano

Argomenti: ,
Pubblicato il: 15-02-2021 16:16 , Ultimo aggiornamento: 18-02-2021 11:02

Se avete maneggiato Excel da principianti, qualche volta, vi sarete accorti che il sistema è molto semplice e soprattutto, di base, prende i dati esattamente come li scriviamo.

Il fatto che formatti una data, ad esempio, pone una sorta di “indizio” sul fatto che in realtà il foglio di calcolo sia molto più complesso di così. E infatti, non solo Excel possiede automatismi per formattare il testo, come abbiamo visto, ma offre anche la possibilità di sfruttare funzioni per effettuare operazioni specifiche che, fatte a mano, sarebbero impossibili o troppo lunghe da realizzare.

Partiamo dall’uso degli operatori che sono un po’ delle funzioni Excel “semplificate”: gli operatori permettono infatti di “combinare” il valore di due celle, ammesso che siano confrontabili tra di loro ed abbia senso farlo. Un operatore matematico potrebbe essere il segno +, ad esempio 12+12=24. Un operatore logico serve invece a legare due valori, che possono valere VERO oppure FALSO (per esempio per verificare se due caselle sono uguali, o se sono superiori ad un valore di soglia prefissato). Un po’ di esempi concreti:

=E(A2>=20; B2<10)

la funzione =E() verifica se le due condizioni inserite all’interno sono vere entrambe (appare la scritta VERO), in tutti gli altri casi restituisce FALSO.

=O(A2>=20; B2<10)

la funzione =O() verifica se le due condizioni inserite all’interno sono almeno una delle due vere (appare la scritta VERO), in tutti gli altri casi restituisce FALSO.

=NON(A2>=10)

Infine la funzione logica NON restituisce falso se la condizione posta come parametro è vera, e viceversa vero se se la condizione posta come parametro è falsa.

Cosa sono le funzioni Excel

Lo scopo delle funzioni di Excel è quello di elaborare dati di altre caselle e mostrare un risultato in una casella apposita. Per fare questo, è indispensabile che le caselle di input siano distinte da quelle di output, ovvero: per restituire il risultato di una funzione ci devono essere gli argomenti (input), ovvero le caselle di ingresso, e una – distinta dalle precedenti – per poter restituire un risultato (output).

Una funzione Excel si scrive genericamente in questa forma:

= nome_funzione(casella1, casella2, …)

dove:

  1. è fondamentale premettere il segno = sempre;
  2. il nome funzione può essere di oltre 500 tipi diversi (tra cui, ad esempio, somma());
  3. gli argomenti (casella1, casella2, …) sono specifiche caselle di Excel identificate da riga (lettera maiuscola) e colonna (numero).

Le funzioni possono essere matematiche, statistiche, finanziarie, di ricerca, di elaborazione testo e molte altre ancora.

Sintassi delle funzioni Excel

Esiste una possibile complicazione: ogni versione di Excel potrebbe avere a disposizione funzioni con nomi diversi, soprattutto se usate la versione in inglese oppure quella in italiano. Una funzione permette pertanto di prendere un input (parametri) e trasformarlo in un risultato, e ogni funzione possiede una specifica sintassi (il modo in cui le scriviamo) che deve essere rispettata, altrimenti si ottiene un errore.

Ad esempio, se vogliamo sfruttare la funzione per determinare data e ora attuale, troviamo più funzioni che possono servire allo scopo, a seconda della versione Excel in uso. Possiamo usare =ADESSO() (senza parametri) oppure =OGGI() oppure, ancora =NOW() se usiamo Excel in inglese.

Funzioni nidificate

Una funziona in Excel è concepita in ottica dichiarativa, e può pertanto essere argomento di ulteriori funzioni “innestate”, del tipo:

Una funzione Excel si scrive genericamente in questa forma:

= nome_funzione( nome_funzione(casella1, casella2, …) )

questo conferisce molta flessibilità alle funzioni, ma deve essere sempre adoperata con cautela come caratteristica, evitando di nidificare troppo per evitare di fare confusione.

Caratteri speciali di Excel

Excel fa uso di alcuni “caratteri speciali” che vengono interpretati in modo specifico. Un esempio di carattere speciali sono i seguenti:

  • l’apice singolo (‘)
  • la virgola (,)
  • il punto e virgola (;)
  • i due punti (:)
  • Il segno uguale va scritto prima di qualsiasi funzione: =, indispensabile per dire ad Excel di fare il calcolo. Se scriviamo una funzione senza il segno uguale davanti, verrà ignorata ed interpretata come testo.

Funzione somma

Per fare la somme di due o più caselle, cioè dei valori numerici contenuti all’interno delle caselle desiderate, si scrive così:

=SOMMA(A1,A2)

che somma i valori delle celle A1 e A2 (che ovviamente dovranno essere riempiti), mentre la funzione in questione andrebbe scritta in una casella qualsiasi che non sia una degli argomenti (quindi nell’esempio non possiamo scrivere la funzione in quel modo nè in A1 nè in A2, ma in A3 sì).

La somma di valori singoli è facile da scrivere, perchè basta iniziare a scrivere =SOMMA( e, dopo aver aperto la parentesi, potremo anche selezionare i valori desiderati come argomento all’interno del foglio, sia caselle continue (drag & drop) che caselle non continue (click col tasto sinistro tenendo premuto ALT). E per fare la somma di un intervallo di caselle? Si scrive così:

=SOMMA(A1:A10)

il che somma i valori delle celle da A1 a A10. Esempio un po’ più complesso:

=SOMMA(A1:A1O;A120:A1000;B1)

il che somma, se andiamo a scomporre l’espressione, (da A1 ad A10) + (da A120 ad A100) + B1 (i ; servono a dividere per gruppi di argomenti, mentre i due punti : concatenano insiemi di caselle). La sintassi può sembrare difficile a prima vista, ma con un po’ di allenamento imparerete a farne uso senza troppi patemi d’animo.

Arrotondare il valore di una somma

Giusto per vedere un esempio pratico di funzione nidificata, in questo caso si applicano le funzioni una di seguito all’altra, nell’ordine prima effettuando la somma delle caselle da A1 a A10, e poi effettua un arrotondamento del risultato ottenuto per eccesso. La stessa cosa che faremmo a mano, solo che in questo caso lo facciamo fare ad Excel.

Funzione somma:

= SOMMA(A1:A10)

Funzione arrotondamento di somma:

= ARROTONDA.ECCESSO( SOMMA(A1:A10); 1)

il parametro 1 indica, in questo caso, che sarà necessario arrotondare alla prima cifra decimale, quindi ad esempio:

=( 12.71 + 12.22 + 21.64 + 23.9 + 12.31 + 43.29 + 21.11 + 23.23 + 12.12 + 43.13 )

darebbe 225,57 come risultato, che comparirà come 225,6 (arrotondato per eccesso). Si noti che il valore originale 225,57 è ottenibile scrivendo:

= ARROTONDA.ECCESSO( SOMMA(A1:A10); 2)

questa volta con due cifre decimali significative.

Contare quanti valori ci sono in una tabella

In questo caso è possibile usare la funzione CONTA.VALORI, che funziona esattamente come la somma e restituisce in una casella risultato, sempre distinta e ovviamente vuota, il numero di valori che gli passiamo come argomento (parametri).

= CONTA.VALORI( parametri )

Contare quanti valori numerici ci sono in una tabella

Per contare quanti dati nella tabella sono numeri possiamo usare CONTA.NUMERI, che funziona esattamente come le altre funzioni e restituisce in una casella risultato, sempre distinta e ovviamente vuota, il numero di valori numerici che gli passiamo come argomento (parametri).

= CONTA.NUMERI( parametri )

Contare quante caselle vuote ci sono in una tabella

Possiamo anche fare un conteggio, volendo, del numero di caselle vuote:

= CONTA.VUOTE( parametri )

Contare il numero di caratteri di una stringa

=LUNGHEZZA(A2)

Se A2 contiene trovalost.it, =LUNGHEZZA(A2)  restituisce il valore 12 (i 12 caratteri che compongono la stringa, ovviamente).

Calcolo di una media di valori

Questo esempio sfrutta le funzioni di Excel per calcolare una media, riga per riga. Bisogna anzitutto creare una colonna con i valori media (in rosso nel video), poi individuiamo i valori che vogliamo mediare. Ora andiamo a scrivere nella colonna MEDIA =MEDIA( seguito dai singoli argomenti).

La funzione non deve essere riscritta ad ogni riga: possiamo trascinare il bordo in basso a destra della casella risultato e trascinarlo giu, tenendo premuto il mouse (tasto sinistro). Questo propagherà in automatico il calcolo per ogni riga successiva, mantenendo la corrispondenza dei valori intatta.

Funzione =SE(A, seVera, seFalsa)

Mostra un valore in corrispondenza del verificarsi di una condizione che gli passiamo come argomento (A), restituendo due valori diversi se (A) è vera o falsa (seVera, seFalsa). Questo serve a dotare il foglio di capacità di “valutazione”, ovviamente sulla base di semplici confronti aritmetici o logici. Esempio:

= SE (B2>5 , “Promosso”, “Bocciato”)

Se il valore di B2 è maggiore a 5, stampa “Promosso”, altrimenti stampa “Bocciato”. Attenzione come sempre alla sintassi, cioè come scriviamo le funzioni: se aprimo una parentesi ( la dobbiamo sempre chiude con ), altrimenti Excel darà un errore di sintassi. Esempio un po’ più elaborati: poniamo di voler determinare quando gli stock di un magazzino richiedono un ordine. per farlo, vogliamo che ci venga segnalato quando uno stock (nella colonna corrispondente) sia minore di 10, condizione da noi fissata come limite. In questo caso, basta scrivere come esemplificato nel video e poi, come al solito, trascinare verso il basso la colonna partendo dal bordo in basso a destra per procedere ad espandere la funzione a tutte le righe successive.

5/5 (1)

Che te ne pare?

Grazie per aver letto Funzioni in Excel: cosa sono e come si usano di Salvatore Capolupo su Trovalost.it
Funzioni in Excel: cosa sono e come si usano (Guide, Assistenza Tecnica, guide excel)

Articoli più letti su questi argomenti:
Trovalost.it è gestito, mantenuto, ideato e (in gran parte) scritto da Salvatore Capolupo