Cosa cambia in Excel tra riferimenti assoluti e relativi

Argomenti trattati: ,
Pubblicato il: 11 Maggio 2021

Oggi parleremo di una caratteristica di Excel poco nota, ma estremamente utile e spesso implicita nell’utilizzo: i riferimenti alle celle, che possono essere assoluti o relativi.

Cosa sono i riferimenti relativi in Excel

L’uso standard di Excel si basa sui riferimenti relativi, il che vuol dire che i riferimenti cambiano in base a come e dove spostiamo le celle. Questo può andare bene per molti casi, ma se ci servono valori di riferimento o valori costanti allora bisogna fare uso dei riferimenti assoluti. Un riferimento relativo è ad esempio:

=SOMMA(A1,A2)

Cosa sono i riferimenti assoluti in Excel

Sono caselle che si possono usare come riferimento assoluto, ad esempio per indicare una percentuale prefissata da applicare a tutti i calcoli del foglio (esempio: l’IVA, che è sempre fissata ad es. al 22%). L’utilità del riferimento assoluto è chiara: non sono costretto a fare il calcolo a mano, e – nel caso del calcolo dell’IVA – ho meno margine di errore perchè vedo sempre chiaramente, e possono tenere conto, del valore che viene utilizzato all’interno dei miei calcoli. Un riferimento assoluto è in questo caso:

SMS Marketing - Skebby

Invia SMS pubblicitari a basso costo - I primi 10 invii sono GRATIS!

Registrati su Skebby

=SOMMA($A$1,$A$2)

Esempio riferimenti assoluti vs. relativi

Poniamo di avere un catalogo prodotti con quantità, descrizione, prezzo, subtotale per ogni riga. Se andiamo ad aggiungere uan colonna IVATO (intendendo il prezzo + IVA), possiamo sfruttare un riferimento per la tabella finalizzato a contenere la percentuale da applicare (che attualmente è al 22% ma potrebbe, in teoria, cambiare in futuro). Per definire un riferimento assoluto basta semplicemente preporre il simbolo $ ad ogni nome di riga e colonna, per cui:

A1

in assoluto diventa

$A$1

3.67/5 (3)

Che te ne pare?

Grazie per aver letto Cosa cambia in Excel tra riferimenti assoluti e relativi di Max Headroom su Trovalost.it
Cosa cambia in Excel tra riferimenti assoluti e relativi (Guide, Assistenza Tecnica, guide excel)

Articoli più letti su questi argomenti: