Cosa cambia in Excel tra riferimenti assoluti e relativi

Aggiornato il: 27-06-2022 00:00
Oggi parleremo di una caratteristica di Excel poco nota, ma estremamente utile e spesso implicita nell’utilizzo: i riferimenti alle celle, che possono essere assoluti o relativi.

Cosa sono i riferimenti relativi in Excel

L’uso standard di Excel si basa sui riferimenti relativi, il che vuol dire che i riferimenti cambiano in base a come e dove spostiamo le celle. Questo può andare bene per molti casi, ma se ci servono valori di riferimento o valori costanti allora bisogna fare uso dei riferimenti assoluti. Un riferimento relativo è ad esempio:

=SOMMA(A1,A2)

Cosa sono i riferimenti assoluti in Excel

Sono caselle che si possono usare come riferimento assoluto, ad esempio per indicare una percentuale prefissata da applicare a tutti i calcoli del foglio (esempio: l’IVA, che è sempre fissata ad es. al 22%). L’utilità  del riferimento assoluto è chiara: non sono costretto a fare il calcolo a mano, e – nel caso del calcolo dell’IVA – ho meno margine di errore perchè vedo sempre chiaramente, e possono tenere conto, del valore che viene utilizzato all’interno dei miei calcoli. Un riferimento assoluto è in questo caso:

=SOMMA($A$1,$A$2)

Esempio riferimenti assoluti vs. relativi

Poniamo di avere un catalogo prodotti con quantità , descrizione, prezzo, subtotale per ogni riga. Se andiamo ad aggiungere uan colonna IVATO (intendendo il prezzo + IVA), possiamo sfruttare un riferimento per la tabella finalizzato a contenere la percentuale da applicare (che attualmente è al 22% ma potrebbe, in teoria, cambiare in futuro). Per definire un riferimento assoluto basta semplicemente preporre il simbolo $ ad ogni nome di riga e colonna, per cui:

A1

in assoluto diventa

$A$1

https://www.youtube.com/watch?v=ySErYyQUGqU



Questo blog pubblica contenuti ed offre servizi free da 11 anni. – Leggi un altro articolo a caso – Per informazioni contattaci
3.67/5 (3)

Ti piace questo articolo? Vota e fammelo sapere.

Cosa cambia in Excel tra riferimenti assoluti e relativi
L'hosting italiano conveniente e funzionale è V-Hosting !
guida funzioni
Torna su